Access to service is disrupted

Incident Report for US Beta Cloud

Resolved

This incident has been resolved.
Posted Jan 30, 2026 - 15:47 UTC

Investigating

Service access has been disrupted since 2026-01-30 15:04:43. Users might experience trouble accessing the mobile app and backend support tools used for monitoring and onboarding. Plume's engineering team is investigating the issue and working on a correction.
Posted Jan 30, 2026 - 15:33 UTC
This incident affected: Misc Services (Optimizer).