Cloud Connectivity Issue

Incident Report for US Beta Cloud

Resolved

This incident has been resolved. The connectivity issue affecting Beta Cloud was caused by a failed infrastructure update that disrupted the AWS Load Balancer Controller, preventing devices from connecting to the cloud. The issue has been fully remediated and all locations are back online.
We apologize for any inconvenience caused.
Incident start: April 2, 2026, 22:00 UTC
Resolved: April 3, 2026 08:15 UTC
Posted Apr 03, 2026 - 12:06 UTC

Monitoring

We have applied a fix for the connectivity issue affecting Beta Cloud. We are monitoring the environment to confirm full stability. We will provide a further update shortly.
Posted Apr 03, 2026 - 08:25 UTC

Investigating

We are currently investigating an issue affecting connectivity on our Beta Cloud environment. Some locations may appear offline or experience degraded service.
Our engineering team has identified the root cause and is actively working on a resolution. We will provide further updates as the investigation progresses.
Posted Apr 03, 2026 - 07:33 UTC
This incident affected: Onboarding services network connectivity (Onboarding - Subscriber cloud controller).